Buscar

Registrarse

¡Gracias por tu registro! ¡Recibirás un correo electrónico con más instrucciones para activar tu cuenta!

username already taken
¿Ya tienes una cuenta? .

Login

¿Olvidaste tu contraseña?
¿Todavía no tienes una cuenta? Registrarse para utilizar el UI-Designer y el foro o para crear tus propios proyectos.
¡Conéctate para crear temas y postear!



missing connection to electric imp

#1 Mayo 16, 2015 20:11:26 by Joergtiedemann

missing connection to electric imp


Hi
im using an electric imp with netio. Works well a few month ago, but now i didn't get any connection to the imp from netio
If i use an webview in netio everthing works well. I use the url
http://agent.electricimp.com/<myimpid>/WlanListe
and every time i press the reload button in the webview i get a http request in the agents log of the imp
But if i use a simple button with the comand
/<myimpid>/ipadstatus

i didn't receive any request in the agents log of the imp
The global settings are:
host:agent.electricimp.com
port:80
protocol:http

Whats goeing wrong ?
I didn't get any request if i press the button.

A few month ago everything works well.
I also tried host:agent.electricimp.com/<myimpid> and commandipadstatus but it's the same
If i put in the following url in the browser
http://agent.electricimp.com/<myimpid>/ipadstatus
i get the request in the imp'sagent and it works ok
I think there is a malfunction in the netio otherwise it should work or whats wrong ?
Can anyone help me ?

I tried another connection to the web service runscope.net to monitor the http requests, but I will get no requests, so it seems that netio didn't send http requests but what I did'nt understand is that it works with a web view. What can I do to solve the problem

Editado Joergtiedemann (Mayo 17, 2015 14:17:21)

#2 Mayo 18, 2015 16:22:40 by david.eickhoff

missing connection to electric imp

Hi there, your issue is caused by a bug in the new iOS version. I submitted a fix which was rejected yesterday. To fix it, you need to add a “GET ” to your command.

like:
GET /<myimpid>/ipadstatus

because the new version can also send POST and PUT requests. An update to support the old syntax is on its way.

#3 Mayo 18, 2015 20:28:50 by Joergtiedemann

missing connection to electric imp

Ok sounds good
But it also works if I add POST
Thanks for your help

#4 Mayo 19, 2015 11:25:54 by david.eickhoff

missing connection to electric imp

right, you can now define the http method.. the update to add backwards compatibility is still in review..